A delay in email delivery

Incident Report for BigPicture

Resolved

We've resolved the issue. All delayed emails have been successfully delivered. There are no further delays.
Posted Mar 17, 2023 - 12:38 CET

Identified

We've identified a delay in our email delivery system - both in sending emails to our clients and in receiving emails from them by our Support.
We're working hard to eliminate the delay. We are sorry for the inconvenience.
Posted Mar 17, 2023 - 09:25 CET
This incident affected: Jira.